System Outage Notice
Resolved
Mar 7, 2026 at 6:18pm UTC
The VoiceStats bot, web dashboard, and all our services are now completely healthy and fully online!
Affected services
Updated
Mar 7, 2026 at 4:40pm UTC
We are still waiting. There are no new updates from the data center yet. We will keep you informed as soon as we receive any news.
Affected services
Updated
Mar 7, 2026 at 3:11pm UTC
Our hosting provider has reported a physical hardware failure (Power Distribution Unit - PDU) in their data center. The data center technicians are currently working on replacing the faulty hardware.
As soon as the hardware replacement is completed, all our services will be fully functional again. Since this is purely a hardware issue, we are waiting for the green light from the data center.
Thank you for your patience and understanding. We will announce it here as soon as the systems are back online. 🙏
Affected services
Created
Mar 7, 2026 at 1:56pm UTC
We are currently experiencing a general access outage with the VoiceStats.
Affected services